Windows Autopilot device import error 806 ZtdDeviceAlreadyRegistered

Posted on Updated on

I was recently setting up some different scenarios and tests using a VM with Windows Autopilot for Windows 10 1803 vs 1809 .  Being lazy, and thinking that I was being “smart”, I just reused the same VM but had a different VHDX disks for 1803 and 1809.  Each Windows instance had a unique hardware hash (see below snipet).

Autopilot GUIDs

However, the import failed with message “Device is already registered to the same Tenant. Error code: 806  –  ZtdDeviceAlreadyAssigned”.

autopilot-error-806

The error message gives a hint to the problem about the device already being registered. But when you delete the system from within the Autopilot profiles section, it seems to NOT actually delete it.  Such that the device isn’t removed and subsequent imports fail with the same error.  This is caused because the delete was triggered to remove the device from the Microsoft Store for Business, but the change hasn’t yet synchronized back into Intune.

My experience has been that there are variance on how quickly the delete is reflected.  So if you need to expedite the scheduled sync cycle, just simply click the Sync button.  Then that should get it back into a position where you can import the new Autopilot hash CSV file successfully.

autopilot-profile-sync

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s