Windows 7 Aero in VMWare Server 2.0.2

Posted on

I use the free VMWare Server 2.0.2 to host my virtual machines (our current workstation images) for development and troubleshooting.  We’re in progress of migrating our desktops to Windows 7 with Office 2010, so naturally I have a VM with the image that we are deploying.  Normally this isn’t a problem.  However, I have experienced a few problems with Win7 on VMWare Server 2:

  1. Graphics fail to function after installing VMWare Tools and only shows a blank black screen once Windows starts
  2. The VM hangs when doing some “intense” graphics processing.  What I really mean by this is the VM will lock up if you do anything too quickly…like browsing the Internet.
  3. The fancy Aero graphics does not function (e.g. Windows is running in “basic” graphics mode)

My solutions to these are

  1. When installing the VMWare Tools, do not install the VGA graphics driver
  2. Increase the VM’s video RAM size by adding the below line to the .vmx file (this particular value equals 64 MB)
    svga.vramSize = “64000000”
  3. OK, so I don’t have this one working yet, but I’m getting there :-)  If you know the answer, please share!
Advertisements

One thought on “Windows 7 Aero in VMWare Server 2.0.2

    herupriadi said:
    June 29, 2010 at 11:04 pm

    thanks for ur articles windows

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s